Docs: Puppet Open Source » Supported Platforms and System Requirements


Puppet Open Source » Supported Platforms and System Requirements

Puppet Open Source Supported Platforms

This page lists supported platforms for the open source version of Puppet. For Puppet Enterprise’s supported platforms visit the PE system requirements page.

Please contact Puppet Labs if you are interested in a platform not on this list.

See Installing Puppet for more details about the packages available for your platform(s).

Puppet 2.7 and Puppet 3.x can run on the following platforms:

Linux

Red Hat Enterprise Linux (and Derivatives)

We publish official packages and run automated testing on the following versions:

Puppet Enterprise also supports RHEL 4, which does not receive packages for open source Puppet.

(Note that RHEL 5 requires an updated Ruby ≥ 1.8.7 from our yum repo.)

This information applies to RHEL itself, as well as any distributions that maintain binary compatibility with it, including but not limited to CentOS, Scientific Linux, Oracle Linux, and Ascendos.

Debian and Ubuntu

We publish official packages and run automated testing on the following versions:

We publish packages for the following versions, but do not run automated testing on them:

  • Ubuntu 13.10 “Saucy Salamander”

Fedora

We publish official packages and run automated testing on the following versions:

  • Fedora 19
  • Fedora 20

Other

  • SUSE Linux Enterprise Server, version 11 and higher
  • Gentoo Linux
  • Mandriva Corporate Server 4
  • ArchLinux

BSD

  • FreeBSD 4.7 and later
  • OpenBSD 4.1 and later

Other Unix

  • Mac OS X, version 10.5 (Leopard) and higher (Puppet 2.7 and earlier also support 10.4)
  • Oracle Solaris, version 10 and higher
  • AIX, version 5.3 and higher
  • HP-UX

Windows

(Puppet version 2.7.6 and higher)

We publish official packages and run automated testing on the following versions:

We publish packages for the following versions, but do not run automated testing on them:

Ruby Versions

Puppet requires an MRI Ruby interpreter. Certain versions of Ruby work better with Puppet than others, and some versions are not supported at all. Run ruby --version to check the version of Ruby on your system.

Puppet Enterprise does not rely on the OS’s Ruby version, as it maintains its own Ruby environment. You can install PE alongside any version of Ruby or on systems without Ruby installed.

windows logo The Windows installers provided by Puppet Labs don’t rely on the OS’s Ruby version, and can be installed alongside any version of Ruby or on systems without Ruby installed.

Ruby version Puppet 2.6 Puppet 2.7 Puppet 3.x
2.1.x No No Supported (3.5 and higher)
2.0.x No No Supported (3.2 and higher)
1.9.3** No No Supported
1.9.2 No No No
1.9.1 No No No
1.9.0 No No No
1.8.7 Supported Supported Supported
1.8.5* Supported Supported No
1.8.6 No No No
1.8.1 No No No

* Note that although Ruby 1.8.5 is fully supported on Puppet 2.6 and 2.7, Ruby 1.8.7 generally gives better performance and memory use. To support the large installed base of RHEL5 systems which ship with Ruby 1.8.5, Puppet Labs packages a drop-in replacement Ruby 1.8.7 package. Read the ‘Enterprise Linux and Derivatives’ section of the Installing Puppet guide to learn how to install these packages.

** Ruby 1.9.3-p0 has bugs that cause a number of known issues with Puppet, and you should use a different release. To the best of our knowledge, these issues were fixed in the second public release of Ruby 1.9.3 (p125), and we are positive they are resolved in p392 (which shipped with Fedora 18). Unfortunately, Ubuntu Precise ships with p0 for some reason, and there’s not a lot we can do about it. If you’re using Precise, we recommend using Puppet Enterprise or installing a third-party Ruby package.

Versions marked as “Supported” are recommended by Puppet Labs and are under extensive automated test coverage. Other versions are not recommended and we make no guarantees about their performance with Puppet.

Prerequisites

Puppet has a very small number of external dependencies:

Dependency Puppet 2.x Puppet 3.x
Facter Required Required
Hiera Optional Required
rgen   Optional

Rgen is only needed if you are using Puppet ≥ 3.2 with parser = future enabled. The official Puppet Labs packages will install it as a dependency.

All other prerequisite Ruby libraries should come with any standard Ruby 1.8.5+ install. Should your OS not come with the complete standard library (or you are using a custom Ruby build), these include:

  • base64
  • cgi
  • digest/md5
  • etc
  • fileutils
  • ipaddr
  • openssl (>= 0.9.8o if using a 3.x Puppet master or newer)
  • strscan
  • syslog
  • uri
  • webrick
  • webrick/https
  • xmlrpc

↑ Back to top